tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Window manager duplication (icewm, bb*)

On Tue, 2018-11-13 at 07:17 +0700, Robert Elz wrote:
>     Date:        Mon, 12 Nov 2018 16:49:51 -0500
>     From:        "David H. Gutteridge" <>
>     Message-ID:  <>
>   | The other advantage 0.65 has for those with vintage hardware is that
>   | it has much more modest dependencies. 0.70+ pulls in perl, gsed, all
>   | the auto* tools, etc. to build, where 0.65 doesn't.
> Yes...   we really could do without all of that.   Of course, most of it is
> going to end up being needed for something else, so the pain happens
> sooner or later anyway.

Fair enough. (On the machine in question, I'm running an almost
pure NetBSD installation, with only a handful of packages from
pkgsrc. But I realize that's the exception.)

>   | >Now blackbox70 is buildable (and working well) again, the old ones
>   | >should no longer matter.
>   |
>   | The present state of the package actually doesn't build on NetBSD,
> It did, when it was first updated (for me anyway).   I am still using the
> version I built then.

Yes, it was broken for NetBSD (8, anyway) more recently.

>   | Having said that, does that mean your PR about blackbox70 not building
>   | can be closed now?
> Probably, though I think it would be good to work out what was causing
> the problem, as more or less the same thing has been reported by others
> in other package I think.  (PR 53007).
>   | Also, having built blackbox70 with my workaround, I'm finding it has
>   | garbled fonts where the 0.65 version does not. I haven't worked out
>   | why that is yet (i.e., perhaps there's some local issue on the
>   | machine in question).
> I am not seeing any issues like hhat.   Not that I put much in the way of
> pressure on its font choices.   But it all "just worked" with my previous
> config (of course, that had been for an earlier blackbox70 version).
> It has been a long time since I swapped, but I vaguelly recall needing to
> redo all the font choices when I switched from the older one to 70.

I built blackbox70 on another machine and couldn't reproduce the font
issues there, so it seems it's not blackbox to blame. I think there's
a rendering issue happening somewhere else in the stack. Basically,
background textures are getting randomly mixed atop fragments of the


Home | Main Index | Thread Index | Old Index