tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Perl5 update

Edgar Fuß <> writes:

>> In general, one has to build from a consistent checkout of pkgsrc.
> Yes, exactly.
>> So saying that p5-* packages in pkgsrc should expect the current perl5 
>> version seems like a simplifying assumption that saves a lot of work,
> I'm afraid you mis-understood me. With "current", I meant "the version 
> included in this checkout of pkgsrc".

That's what I was trying to say.    When one does a cvs checkout/update
to some branch or date, then it's the p5-* package in that checkout can
expect that the perl5 package in that checkout is installed, or more
carefully can depend on it.

>> but on the other hand expects people to replace their perl interpreter 
>> with the one from the pkgsrc version they are using.
> I don't get that.
> If I have 5.14 installed and build a package containing a Perl Module 
> from a pkgsrc checkout that includes 5.16, I get 5.16 built because I 
> get a dependency on perl>=5.16<5.18, don't I?

Probably.  But if building any perl module requires that you have the
up-to-date (with respect to your checkout) perl version, then why is
this OR dependency method needed?   Each p5-* depends on modules and the
current base version, so there are no choices.

Attachment: pgpTO94jXGd0H.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index