tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Remove of Ruby 1.9.2 support

On 9/16/2012 04:57, David Holland wrote:
On Sun, Sep 16, 2012 at 11:49:02AM +0900, Takahiro Kambe wrote:
  >  >  Shouldn't this be done *after* branching rather than before?
  >  Then, it would be difficult to maintain pkgsrc's branch.

Only if there's any actual maintenance that needs to be done. Leaving
an old package alive on the branch (and ignoring it there) doesn't
cost any more than removing it, and it's better for people who want
some time to migrate or finish migrating.

Hmmm, not really true. This is a multiversion package, so leaving 1.9.2 in place causes an extra version of every ruby package (minus 1.8-only packages) to build. That's a big cost on a bulk build.

Also theoretically we're supposed to announce package removals one
full quarterly branch ahead of actually doing them.

however, as far as I'm concerned it's ultimately up to you; if it
weren't for all the work you do we probably wouldn't have ruby

I whole-heartedly support the removal of this package that doesn't represent any benefit over 1.9.3. I hope the python package maintainers follow suit. Why do we not have only one multiversion per API? In other words, shouldn't we be trying to converge to python 27 and 32 only?

Home | Main Index | Thread Index | Old Index