tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Any issue with upgrading lang/tcl to 8.5.12 ?

On 8/17/2012 08:52, Aleksej Saushev wrote:
John Marino<>  writes:
I already know lang/tcl-expect will not build on tcl 8.5, and
probably requires an update to the latest source (it's pretty

Yes, and this is hard blocker.

My vote is to bite the bullet, move to the latest version, and
fix the problems later.  I can run these through pbulk and see
what regresses first of course.

Not until you demonstrate at least functional Expect.

I find it counterproductive to "bite the bullet" and kill such
corner-stone software used in testing and automation like Expect
just to import something comletely unknown or simply update.
Anyhow, I welcome your work in this area.

You suspected that I didn't use tcl, but I do use expect through tcl-expect. This drives the GCC testsuites and personally I must have it.

expect 5.43.1 was released 7 Feb 2004. The latest is 5.45 from 2010. There's even a wip/tcl-expect at 5.43. I "expect" that resolving this blocker will be as simple as updating an 8 y/o package. I'll look into this myself.


Home | Main Index | Thread Index | Old Index