tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]


On Thu Jul 09 2009 at 08:49:53 +0300, Jukka Marin wrote:
> On Tue, Jun 02, 2009 at 02:10:06PM +0300, Jukka Marin wrote:
> > I have been using a setup where my $HOME is located on a NetBSD NFS server
> > (for 10+ years).  Every now and then something goes wrong with NFS and
> > all accesses to /home cause the process enter disk wait (D in ps listing).
> > No matter how long I wait, the disk wait never completes.  I can't even
> > shutdown and reboot the client system properly because shutdown fails
> > to unmount the NFS partition(s).  At the same time, all other NFS mounts
> > from the same server work just fine.
> It happened again.
> After the last discussion, I changed /home to use NFS over TCP and it has
> been working well so far.  Yesterday, another UDP mounted partition died
> in the middle of a compilation process.  I couldn't umount the partition,
> not even with umount -f.  When I ran shutdown -r, it killed a bunch of
> processes and then - nothing.  I tried sync, it hang.  I tried reboot,
> it didn't.  Even halt didn't do anything useful.
> The only way to "fix" the dead NFS mount was hitting the reset button
> (which forced a parity rewrite of a 1 TB raidframe disk and fsck of
> several largish partitions).
> I'm using TCP for all NFS mounts now.. we'll see if that helps.  It would
> be great if one could get over an NFS problem without the reset button,
> though....

I've pretty much stopped using the in-kernel nfs client on my desktop
(laptop) and use either rump_nfs or sshfs.  I don't use them for /home,
though, and you will have issues at least with sshfs in a multiuser

Home | Main Index | Thread Index | Old Index