tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

reboot fails to reboot -- was Re: NFS

On Wed July 8 2009 23:49:53 Jukka Marin wrote:
> After the last discussion, I changed /home to use NFS over TCP and it has
> been working well so far.  Yesterday, another UDP mounted partition died
> in the middle of a compilation process.  I couldn't umount the partition,
> not even with umount -f.  When I ran shutdown -r, it killed a bunch of
> processes and then - nothing.  I tried sync, it hang.  I tried reboot,
> it didn't.  Even halt didn't do anything useful.

It would be nice if reboot could be made to force a reboot.  Perhaps using a 
flag.  I have a NetBSD 5.0 Web server where any process accessing the Web 
content partition would get stuck in state D (disk wait) waiting on "tstile".  
(I suspect this is a wapbl issue since I have not seen the problem since 
remounting the file system without -o log.)   Reboot hung after printing 
"syncing disks", requiring physical access to restore the server.


Home | Main Index | Thread Index | Old Index