Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: epoch32 Fails to Boot on psion 5 MX

On 4 June 2014 23:41, Tom Jones <jones%sdf.org@localhost> wrote:
On Wed, Jun 04, 2014 at 10:11:29PM +0100, David Brownlee wrote:
> How much memory is in the 5? In
> http://mail-index.netbsd.org/current-users/2013/04/21/msg022569.html its
> mentioned that greater than 4M is required to boot.

The 5 only has 4M, I had seen the limit, but for some reason had 4M as minimum
in my head.

Might be nice for the bootloader to print a warning in that case. Presumably since it can know the amount of memory and the size of the file to load it could generate it dynamically? (Thinking of a kernel with embedded ramdisk on an 8M machine)
> For the 5MX does the output from
> http://ftp.netbsd.org/pub/NetBSD/misc/kiyohara/epoc32/euhal/euhal.exe show
> anything interesting?

I hadn't seen this tool, but when I run it, it does show the correct version
name. I think I will try integrating into e32boot.

I wonder if there is anything else that e32boot is probing which is getting bad data similar to the version name and throwing things off - or maybe even in the kernel?

> Also - did you boot netbsd+wmlcd rather that just netbsd - booting netbsd
> gives the same garbled screen for me, but netbsd+wmlcd shows the dmesg down
> to a "root device: " prompt...

I have been trying both kernels, but hadn't netbsd+wmlcd with my modified
bootloader for a while. Just tried it now, but no such luck.

I have tried serial a few times, but haven't been able to see anything. I
haven't been able to figure out what the baud rate for the serial port should
be. Any ideas?

I need to locate my serial cable first...

Are you able to run an epoc app and confirm the serial port is working fine with whatever you have on the other end? However given the wmlcd kernel crashes my supposition would be that you're not seeing serial output for the same reason - something is choking before that point.

Possibly three options
a) Work out what is different (probably causing the version mismatch), and tweak to get the kernel running on your 5MX
b) See if you can get the bootloader to work on the 4M Psion5 (probably adding some checks and warnings would be useful anyway)
c) Pickup another 5MX or 8MB 5 :)

I suspect your preference (as mine would be) would be towards a) :)

Home | Main Index | Thread Index | Old Index