Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Dockstar (like SHEEVAPLUG) panics at init with -current after Aug 31, 2012

On 6/01/2013, at 11:15 PM, Martin Husemann <martin%duskware.de@localhost> wrote:

> On Sat, Jan 05, 2013 at 08:15:11PM -0700, Andy Ruhl wrote:
>> Are we still calling this a problem?
> Sure it is a problem - none of the kernels in question seems to be modular,
> so it can't be broken module loading.

I don't think modular kernels work on evbarm (and maybe not on any arm). A 
while back I wrote the necessary dynamic linking code in the kernel to support 
arm ELF modules and it looked fairly straightforward, but it still blew up with 
weird stack corruption. I even double checked that I was flushing the caches 
like everyone else, so I feel a bit hard done by.

> Can you try to mount a tmpfs somewhere and (if that does not crash) use
> it a bit?

tmpfs after boot seems to be mostly OK. I ran "/dev/MAKEDEV -M init" in /mnt 
and it worked fine. I ran "/dev/MAKEDEV -M -M init" and it didn't work so fine. 
It didn't panic, but it failed with error 1 creating the device node 
temp_console. Since it did in fact manage to create temp_console, something a 
bit odd was going on. I've broken that NetBSD image and misplaced my backup, so 
I can't look further right now.

> If any of that steps fails, please file a PR about it.

Actually, we should file a PR regardless of any step failing because we know 
the kernel panics in at least one situation. I'll try and raise a PR this 
evening. I've done all this before and have all the necessary bits and pieces 
to produce a useful PR, I just have to pull them all together but I'm supposed 
to be doing other things right now.


Home | Main Index | Thread Index | Old Index