Port-amiga archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD/amiga sysinst (Was: Video of NetBSD/amiga 10.0_BETA network install in real Amiga 1200)

On Sun, 12 Mar 2023 at 22:32, Carlos Milán Figueredo
<cmilanf%hispamsx.org@localhost> wrote:
> From: David Brownlee <abs%netbsd.org@localhost>
> Sent: miércoles, 8 de marzo de 2023 22:49
> Hi David!
> > 1) Multiple hard drives Just Work
> Great! :)

Follow up on this - in fs-uae there is *something* odd going on with
multiple hard drives - the first hard drive always shows up with 0
sectors. Will come back to this one

> > 2) Arrow keys do not seem to be mapped through in
> > fs-uaw Are arrow keys mapped through to the console
> > correctly on real hardware?
> It works well on real hardware and it worked well for me in WinUAE.

OK - so interestingly arrow keys work in fs-uae running under Windows,
but not running under NetBSD. Which is just more strange (but at least
it's not a NetBSD/amiga issue).

> > 3) I was unable to get a CD image to show up
> > - MESSAGE: Option failed: cpuboard_ext_rom_file = Blizzard_SCSI_Kit_IV_v8.5.bin
> > - MESSAGE: One of the following expansion boot ROMs is required: - Blizzard 1240/1260 (32k) ... and no scsi > nor CD-ROM device is detected in NetBSD. Would anyone have any ideas?
> It looks like you need the SCSI ROM to make it work. I faced a similar issue with the A2091 emulation, I needed to use the ROM file from the card to make the SCSI work.

I found a ROM, which makes fs-uae now crash midway through NetBSD
booting to autoconfigure. So now I'm building a debug version of
fs-uae to see what I can find.

> > 5) Network
> > Attempting to run dhcpcd to configure the network
> > gives a "MESSAGE: Error loading qemu-uae plugin" message,
> > and it fails to get an IP address. qemu-uae seems to be
> > related to PPC, so not entirely sure why its showing up
> > for a plain m68k emulated mac. Does anyone else have
> > networking working in fs-uea?
> I don't have any idea on how FS-UAE interfaces with the host network. WinUAE uses SLIRP or WinPCap, so FS-UAE must have gone a different way. I remember as well that in WinUAE I was not successful emulating PCMCIA ethernet, but A2065 worked well.

This may be the killer for me with fs-uae - even under windows, and
with the qemu-uae plugin in place I cannot get an IP address via the
emulatore A2065, nor see any traffic. I... may have to switch to
testing under WinUAE, which is a real pain as I have to run it
(obviously) under Windows. foo :)

> > 6) The font
> > That "packed as tight as can be, big chunky font"...
> > 'nuff said :)
> ?

The font brought back memories :)


Home | Main Index | Thread Index | Old Index