pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problem building on LinuxMint (Ubuntu)

* On 2017-05-04 at 13:02 BST, Robert Nestor wrote:

> 5) Rebooted as there was some message indicating not everything would be available until the system was rebooted

No need for this, not sure where the message would have come from?

> 6) Tried building a package:  “cd /usr/pkgsrc/pkgtools/pkg_chk ; bmake install”
> 	Linux make doesn’t work and the on-line instructions for pkgsrc use on Linux aren’t clear about this, but bmake seems to be required.

Yes, you'll always need to use bmake when bootstrapping, and ensure it
is the one that you bootstrapped and not from a different prefix.

> pkg_create: can't stat `/usr/pkgsrc/pkgtools/cwrappers/work/.destdir/usr/pkg/libexec/cwrappers/as-wrapper'

The actual error would have come earlier, would need to see the full

> Can someone provide me a clue here?  I’ve tried doing all this a “root” as well just in case it was some permissions issue, but I get the same results.

You need to be root unless you use --unprivileged.

One of the most common causes of failure is trying to restart a build
that was previously started with different settings.  It sounds like
you've changed various things, so it's likely there is a mismatch
somewhere.  I'd start by removing all of the work directories
(pkgsrc/*/*/work) then trying again.


Jonathan Perkin  -  Joyent, Inc.  -

Home | Main Index | Thread Index | Old Index