pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problem building on LinuxMint (Ubuntu)

Thanks!  I understood the need for bmake, my comment was intended to point out that it wasn’t obvious from the on-line documentation on how to get pkgsrc running on a Linux system.

Not sure I understand your comment “need to use bmake when bootstrapping”.  Does the bootstrap script try to use bmake to bootstrap and thus my installation procedure needs to install bmake BEFORE i do the bootstrap?  Since bmake isn’t included in the LinuxMint/Ubuntu base system after I install it any place it will be used should always get the same copy.

Anyway, I cleaned out all the work directories and tried building again.  Here’s the complete log file, but I’m not sure it contains any other error messages.  If it does I missed them when I scanned the file.

Attachment: typescript
Description: Binary data


On May 4, 2017, at 7:10 AM, Jonathan Perkin <> wrote:

> * On 2017-05-04 at 13:02 BST, Robert Nestor wrote:
>> 5) Rebooted as there was some message indicating not everything would be available until the system was rebooted
> No need for this, not sure where the message would have come from?
>> 6) Tried building a package:  “cd /usr/pkgsrc/pkgtools/pkg_chk ; bmake install”
>> 	Linux make doesn’t work and the on-line instructions for pkgsrc use on Linux aren’t clear about this, but bmake seems to be required.
> Yes, you'll always need to use bmake when bootstrapping, and ensure it
> is the one that you bootstrapped and not from a different prefix.
>> pkg_create: can't stat `/usr/pkgsrc/pkgtools/cwrappers/work/.destdir/usr/pkg/libexec/cwrappers/as-wrapper'
> The actual error would have come earlier, would need to see the full
> log.
>> Can someone provide me a clue here?  I’ve tried doing all this a “root” as well just in case it was some permissions issue, but I get the same results.
> You need to be root unless you use --unprivileged.
> One of the most common causes of failure is trying to restart a build
> that was previously started with different settings.  It sounds like
> you've changed various things, so it's likely there is a mismatch
> somewhere.  I'd start by removing all of the work directories
> (pkgsrc/*/*/work) then trying again.
> Cheers,
> -- 
> Jonathan Perkin  -  Joyent, Inc.  -

Home | Main Index | Thread Index | Old Index