pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Gtk-WARNING issues after upgrading packages (SOLVED)

On Sun, May 12, 2013 at 06:39:25PM +0000, David Holland wrote:
> On Sat, May 11, 2013 at 02:51:55PM -0500, Eric Haszlakiewicz wrote:
>  > ...
>  > ---May 11 12:49:46: installing gdk-pixbuf2-2.26.5nb2...
>  > Shared object "" not found
>  > ---May 11 12:49:46: installing cairo-1.12.14nb1...
>  > pkg_add: A different version of cairo-1.12.14nb1 is already installed: 
> cairo-1.12.14nb1
>  > ...
>  > 
>  > I suspect that was the cause of the problem.  Perhaps pkgin didn't
>  > install the packaged in the proper order.
> When a library soname gets bumped, there's a window between the commit
> of the library package and the revbump of the packages that use it. If
> you update during this window you can end up with packages whose deps
> are satisfied but whose shared libs don't actually work. Is it
> possible that this is what happened?

I think that's irrelevant for my use case.  I'm not building anything.
I was ugrading using the pre-built packages.

> I know there's some machinery in the package tools for also validating
> shared library references like this, but as I recall it's not finished
> or not enabled by default or something like that.

I don't know about actually validating references, but if you run 
"pkg_info -B ... | grep REQUIRES"
it will show you what actual library files a package needs.

> Anyway you should be able to recover from this by forcibly updating or
> recompiling libffi and then resolving the resulting UNSAFE_DEPENDS;
> unfortunately because glib2 depends on libffi, this requires
> recompiling nearly everything. :-/

The commands run just fine now, once everything got updated.  I don't
get any errors about not found, so I think it was just during
the trasition period while some packages were updated, but others were

I think the recovery might actually require re-installing everything that
had a problem, to get each package's install scripts to run again.  Some of
the commands that I ran manually to get things working are things that I found
in the install scripts, but I don't know if there is anything else I missed.


Home | Main Index | Thread Index | Old Index