pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problem compiling lang/tcl under Darwin/64-bit

Makoto Fujiwara <> writes:

> I have the very much similar problem with
> lang/tcl on Mac OS X 10.6.1,
>  With manual intervetion, I did manage to package this 8.4.18 on Mac OS X,
> but I had another problem on x11/tk (84).
> So I have tried wip/tcl85 and wip/tk85.
> These two has minor PATH discrepancy on Mac OS X only.
>   tcl85 placed -> /usr/pkg/lib/libtclstub8.5.a
>   tk85 wants   -> /usr/pkg/lib/tcl8.5/libtclstub8.5.a
> I have checked the same thing on NetBSD/amd64 6_BETA2,
> and it is fine, no problem at all.
> Does any one have fix ?

Yes. I think that wip/tcl85 and wip/tk85 are wrong.
Unfortunatly, TCL/Tk are not compatible enough, thus you cannot just
replace 8.4 package with 8.5 package.


Home | Main Index | Thread Index | Old Index