pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: hplip new in main pkgsrc: special considerations needed?

Thomas Mueller <> writes:

> Are there any special considerations needed regarding kernel
> config and modules needed for hplip to work on a USB HP LaserJet?
> Like disabling ulpt?

I recently (March 2012) got a printer/scanner working with hplip
(based on a NetBSD package for "hplip3" in category "wip" on a web
server in Sweden), and I definitely had to disable ulpt from the
kernel so that the device could be attached as ugen.

I also had a bad time with the permissions on the /dev/files; my
notes say:

#"ktruss" on "cupsd" shows that the "hp" back end gets:
#     setgid(0x3ee)               = 0  [1006=lp]
#     setgroups(0x1, 0x648c0)     = 0  [array - can't tell contents]
#     setuid(0x3eb)               = 0  [1003=lp]
# It looks as though user or group "lp" must be able to talk to 
# (write to) at least /dev/usb0 and /dev/ugen0.00.  I tried making
# them available to a new group ("usb") of which lp was made a 
# member, and I tried making them available to lp's login group
# ("sys"); neither worked.  Reluctantly:

   chgrp lp   /dev/usb[0-7] /dev/ugen*
   chmod 0660 /dev/usb[0-7] /dev/ugen*

After that I still had trouble adding the printer from the CUPS
web interface ("Unable to get list of printer drivers: Internal
Server Error", which is found in log as:  E [17/Mar/2012:19:35:22
-0400] PID 26842 (/usr/pkg/libexec/cups/daemon/cups-driverd) crashed
on signal 11).  So I found the PPD file location and invoked the
set-up program at the command line (the printer model is "PSC 1510"):

   pkg_info -L hplip | grep 1510

I couldn't print the CUPS test page properly, but my other tests
passed so at that point I declared "good enough":

#   - HP test page: passed (above)
#   - text (echo "Hello world" | lpr): passes
#   - a2ps: passes
#   - firefox print Alcor home page: passes
#   - gimp print image with Gutenprint: passes
#   - CUPS test page: FAILS: prints:
#           #CUPS-COMMAND
#                        PrintSelfTestPage
#     ... as though the foomatic filters are not used?
# Anyway, I can live with a failing CUPS test page.

Note that I had to experiment with PPD files to select the right one.

Anyway, the whole ordeal took several days of ktrussing and cursing.
I hope this saves you some aggravation...

Ms. Anne Bennett, as a private citizen:
Also reachable more officially at work:

Home | Main Index | Thread Index | Old Index