pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: hplip new in main pkgsrc: special considerations needed?

From Anne Bennett <>:

> I recently (March 2012) got a printer/scanner working with hplip
> (based on a NetBSD package for "hplip3" in category "wip" on a web
> server in Sweden), and I definitely had to disable ulpt from the
> kernel so that the device could be attached as ugen.

> I also had a bad time with the permissions on the /dev/files; my
> notes say:

> #"ktruss" on "cupsd" shows that the "hp" back end gets:
> #
> #     setgid(0x3ee)               = 0  [1006=lp]
> #     setgroups(0x1, 0x648c0)     = 0  [array - can't tell contents]
> #     setuid(0x3eb)               = 0  [1003=lp]
> #
> # It looks as though user or group "lp" must be able to talk to
> # (write to) at least /dev/usb0 and /dev/ugen0.00.  I tried making
> # them available to a new group ("usb") of which lp was made a
> # member, and I tried making them available to lp's login group
> # ("sys"); neither worked.  Reluctantly:

>    chgrp lp   /dev/usb[0-7] /dev/ugen*
>    chmod 0660 /dev/usb[0-7] /dev/ugen*

> After that I still had trouble adding the printer from the CUPS
> web interface ("Unable to get list of printer drivers: Internal
> Server Error", which is found in log as:  E [17/Mar/2012:19:35:22
> -0400] PID 26842 (/usr/pkg/libexec/cups/daemon/cups-driverd) crashed
> on signal 11).  So I found the PPD file location and invoked the
> set-up program at the command line (the printer model is "PSC 1510"):

>    pkg_info -L hplip | grep 1510
>    hp-setup

> I couldn't print the CUPS test page properly, but my other tests
> passed so at that point I declared "good enough":

> # TESTS:
> #   - HP test page: passed (above)
> #   - text (echo "Hello world" | lpr): passes
> #   - a2ps: passes
> #   - firefox print Alcor home page: passes
> #   - gimp print image with Gutenprint: passes
> #   - CUPS test page: FAILS: prints:
> #           #CUPS-COMMAND
> #                        PrintSelfTestPage
> #     ... as though the foomatic filters are not used?
> #
> # Anyway, I can live with a failing CUPS test page.

> Note that I had to experiment with PPD files to select the right one.

> Anyway, the whole ordeal took several days of ktrussing and cursing.
> I hope this saves you some aggravation...

This gives me some ideas.  Experience so far is all failure on NetBSD, FreeBSD 
and Linux, though in the case of Linux, maybe the Slackware version was too old.
Or rather, the package with that version of Slackware (13.0) might have been 
too old.

Either hplip doesn't see the printer at all, or can't install the binary 
plugin; I tried both Ethernet and USB.

I can try again with a newer hplip on the new computer.  On the old computer, 
where I built hplip 3.11.1 from pkgsrc-wip, it failed to recognize the device 
even when I tried by Ethernet.  This was with NetBSD 5.1_STABLE.

Maybe I could try again, this time checking the dmesg.boot or logging in to the 
wireless router to find the IP address of the printer and giving that to the 

I can also see if the MS-Windows software works with Wine (build on new 

Ultimately I also want to try with Linux, which might have a better chance than 
BSD (Net, Free or any other).

There is no assurance I will be able to install NetBSD on the new computer, 
though FreeBSD 9.0-STABLE is successfully installed.


Home | Main Index | Thread Index | Old Index