pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: print/ghostscript - "cups" option shouldn't be default?

On Fri, May 20, 2011 at 09:54:50AM -0400, D'Arcy J.M. Cain wrote:
> On Fri, 20 May 2011 09:19:09 -0400
> Greg Troxel <> wrote:
> > I think the problem is that ghsotcript, when compiled with cups support,
> > not only has a few extra programs, which would be fine, but depends on
> > cups.
> Is it a real dependency?  Perhaps we can simply remove the DEPENDS from
> ghostscript, enable cups support and simply make cups depend on
> ghostscript.  If ghostscript will actually build without cups installed
> then we don't care if it is.  If someone wants GS they can install that
> and get the seven support files for cups and if they want cups they can
> install that and know that ghostscript will be there with the required
> support whether it is already there or built as a dependency of cups.

It seems it is a real dependency.  I have just removed the line that
defined depend and it stopped at an error trying to include some cups

There was print/ghostscript-esp, but it was merged into
print/ghostscript, right?  It is more difficult that I thought.  What
would be a good solution?  Let it as it is?

Silas Silva

Home | Main Index | Thread Index | Old Index