pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Pkgsrc 2011Q1 modular xserver broken.


I'm using pkgsrc-2011Q1 and have built the modular xorg server from 
pkgsrc(including meta pkgs:fonts libs drivers and apps).

After a clean install of NetBSD 5.0.1 without the xsets I insalled the packages 
created from the build.

When I run the x server /usr/pkg/bin/X all I get is a blank screen.

I then restored my old setup with the native xserver Xorg 1.4.2. X was working 

I tried some investigating, and did an install of NetBSD 5.0.1 and the modular 
xserver Xorg 1.6.5 on a qemu emulation. I had to boot without SMP or apci for x 
to detect the video card.  Still under the emulation no x, just a black screen, 
same as before.  So I did another emulation with the full install and Xorg 
1.4.2 the one shipped with NetBSD worked in both modes in smp and acpi disabled 
and with them enabled.

So my questions are:
Has anybody successfully run the modular xserver from pkgsrc-2011Q1?


What xserver does NetBSD 5.1 ship with? does it work in a qemu emulation?

Any help or information will be appreciated.

Thanks in advance,


Home | Main Index | Thread Index | Old Index