pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Pkgsrc 2011Q1 modular xserver broken.

On Sun, Apr 24, 2011 at 01:23:04AM -0400, Nathanial Sloss wrote:
> Hi
> I'm using pkgsrc-2011Q1 and have built the modular xorg server from 
> pkgsrc(including meta pkgs:fonts libs drivers and apps).
> After a clean install of NetBSD 5.0.1 without the xsets I insalled the 
> packages created from the build.
> When I run the x server /usr/pkg/bin/X all I get is a blank screen.
> I then restored my old setup with the native xserver Xorg 1.4.2. X was 
> working again.
> I tried some investigating, and did an install of NetBSD 5.0.1 and the 
> modular xserver Xorg 1.6.5 on a qemu emulation. I had to boot without SMP or 
> apci for x to detect the video card.  Still under the emulation no x, just a 
> black screen, same as before.  So I did another emulation with the full 
> install and Xorg 1.4.2 the one shipped with NetBSD worked in both modes in 
> smp and acpi disabled and with them enabled.
> So my questions are:
> Has anybody successfully run the modular xserver from pkgsrc-2011Q1?
> and,
> What xserver does NetBSD 5.1 ship with? does it work in a qemu emulation?
> Any help or information will be appreciated.

I saw something similar on QNX.  In x11/libX11/Makefile I
had to use:

CONFIGURE_ARGS+=        --without-xcb

The default was --with-xcb.

I haven't had a chance to debug further yet and not sure
if it's the same issue you're seeing but it's something
to try...  IIRC one of xcb's features is improved threading
support and I was also on smp on QNX.



Home | Main Index | Thread Index | Old Index