pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

How to automatically update dependencies when building a package?

How do I get pkgsrc to automatically update dependencies when a too-old version 
is already installed?

FreeBSD ports would do this automatically, but my attempted build of links-gui 
was stopped when libpng-1.4.5 was already installed and links-gui needed 1.5.1. 
 I suppose I could do "make replace" on the offending package each time, but it 
is annoying and inefficient to be stopped every time a dependency needs 

Am I too tired now and overlooking something?  Can I do something directly from 
/usr/pkgsrc/www/links-gui directory when package has not yet been installed?


Home | Main Index | Thread Index | Old Index