pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkgsrc on Solaris - coexisting with already installed software

On Tue, Nov 24, 2009 at 11:47:50AM -0500, Mikhail T. wrote:
> Larson, Timothy E. ???????(??):
> > You can always build/install the pkgsrc versions...nobody says you have to 
> > start USING those versions right away.  Two installations of the same 
> > software can very often coexist.
> >   
> Ok, I'll grant you, that coexisting with optional locally hand-built
> software is unduly hard. But to rebuild your own versions of what comes
> with the OS is gratuitous, IMHO... OpenSSL, zlib, bzip2 all come with
> Solaris-8 and are of reasonably recent versions. Rebuilding these from
> pkgsrc should be an option...

If those are in /usr/lib and the necessary headers exist and they are
new enough, then  they should be picked up automatically. Given the age
of Solaris 8, I don't really think the "new enough" is likely though.


Home | Main Index | Thread Index | Old Index