pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: tnftp build error on Solaris 10 with Sun Studio compiler [SOLVED]

15 okt 2009 kl. 07.40 skrev Jörn Clausen:


I haven't looked at your problem in detail, but

PATH=/opt/sunstudio12.1/bin/:/usr/pkg/sbin/:/usr/pkg/bin/:/usr/ sbin:/usr/bin

I'd include /usr/ccs/bin, as it contains the linker and the assembler
(and Sun's original "make"). I'm not sure if they are picked up by Sun
Studio automatically, but having this in PATH can't hurt.

This actually solved the problem; tnftp now compiles successfully! Good job Jörn, but thanks to all of you!

Since I cannot find `ld` anywhere in the Sun Studio package, I presume that Sun have gone from using the incremental linker previously shipped with Sun Studio, and now relies on the system's linker, residing in /usr/ccs/bin.

I've written down my experiences with pkgsrc on Solaris here:

The page starts to get stale, at least if/when lang/gcc44 works on
Solaris, it will need a rewrite.

A follow-up question on this one; Should one still apply this patch (assuming one would like to use gcc34 instead of Sun Studio)? -->

You say "apply this patch to the freshly installed gcc", do you mean one should apply the patch to the gcc34 (for example) sources and then rebuild it, using itself (after having bootstrapped it once)?

Thank you,


Home | Main Index | Thread Index | Old Index