pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: net/ldns installation problem on MacOSX

On Sep 29, 2009, at 2:01 PM, Fredrik Pettai wrote:
On Sep 29, 2009, at 1:24 PM, OBATA Akio wrote:
On Tue, 29 Sep 2009 18:02:12 +0900, Fredrik Pettai <> wrote:

It boils down to net/ldns Makefile and the line CONFIGURE_ARGS+= --
SHA256 and SHA512 support doesn't seem to be included in the openssl
version in MacOSX (according to nm /usr/lib/libcrypto.dylib | grep -i

I tried to fix this problem by installing pkgsrc's security/openssl
(which includes the new sha modes) and adding CONFIGURE_ARGS+= -- with-
ssl=${PREFIX} in net/ldns/Makefile. But, unfortunately didn't help

Does someone know a work-a-round or a proper fix for this problem?
(making CONFIGURE_ARGS+= --enable-sha2 work, that is...)

I don't know sha2 support should be enabled or not, but

If yes,
BUILDLINK_ABI_DEPENDS.openssl+= openssl>=0.9.8

I actually tried that as well, but it didn't help :-(

checking for SHA256 and SHA512... checking for SHA256_Init in - lcrypto... no
configure: error: SHA2 enabled, but no SHA2 functions found in OpenSSL
*** Error code 1

bash-3.2# nm /usr/pkg/lib/libcrypto.0.9.8.dylib | grep SHA256_Init
0000d300 T _SHA256_Init

bash-3.2# nm /usr/lib/libcrypto.0.9.7.dylib | grep SHA256_Init

Could it be the problem that configure puts in -L/usr/lib before -L/ usr/pkg/lib in the test, and how could one fix/reverse that the best way?

configure:14270: gcc -o conftest -Wwrite-strings -W -Wall -O2 -g -pipe -O2 -I/usr/include -no-cpp-precomp -isystem /usr/include -I/usr/ include -I/usr/pkg/include -L/usr/lib -L/usr/pkg/lib -L/usr/pkg/lib conftest.c -lcrypto -lcrypto >&5
Undefined symbols:
  "_SHA256_Init", referenced from:
      _main in cc3i6Ug5.o

Home | Main Index | Thread Index | Old Index