pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: net/ldns installation problem on MacOSX


On Sep 29, 2009, at 1:24 PM, OBATA Akio wrote:
On Tue, 29 Sep 2009 18:02:12 +0900, Fredrik Pettai <> wrote:

It boils down to net/ldns Makefile and the line CONFIGURE_ARGS+= --
SHA256 and SHA512 support doesn't seem to be included in the openssl
version in MacOSX (according to nm /usr/lib/libcrypto.dylib | grep -i

I tried to fix this problem by installing pkgsrc's security/openssl
(which includes the new sha modes) and adding CONFIGURE_ARGS+= -- with-
ssl=${PREFIX} in net/ldns/Makefile. But, unfortunately didn't help

Does someone know a work-a-round or a proper fix for this problem?
(making CONFIGURE_ARGS+= --enable-sha2 work, that is...)

I don't know sha2 support should be enabled or not, but

If yes,
BUILDLINK_ABI_DEPENDS.openssl+= openssl>=0.9.8

I actually tried that as well, but it didn't help :-(

checking for SHA256 and SHA512... checking for SHA256_Init in - lcrypto... no
configure: error: SHA2 enabled, but no SHA2 functions found in OpenSSL
*** Error code 1

bash-3.2# nm /usr/pkg/lib/libcrypto.0.9.8.dylib | grep SHA256_Init
0000d300 T _SHA256_Init

bash-3.2# nm /usr/lib/libcrypto.0.9.7.dylib | grep SHA256_Init

If no,
detect openssl version same as lang/python25 and pass --enable-sha2 conditionally
(and also PLIST conditionally).

As I interpret this, woundn't that just disable --enable-sha2 for my build? Or does security/openssl/ add glue so the package actually will use security/openssl instead of the native openssl? I tried to force using .include "../../security/openssl/" in the Makefile, but with the same result.

Is there someone else running MacOSX that could try installing net/ ldns to see if it's only me having this problem?


Home | Main Index | Thread Index | Old Index