pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: gcc on i386 (NetBSD 5.0.1): circular dependency

????????? ?.?. schrieb:
* Dirk H. Schulz <> [2009-08-10 13:42:00 

Thomas Klausner schrieb:
On Mon, Aug 10, 2009 at 12:54:50PM +0200, Dirk H. Schulz wrote:
I have set up a new machine with NetBSD 5.0.1 (minimum installation), installed cvs as binary package and pkgsrc via cvs (2009Q2).

Now I cannot compile lots of things because of gcc 2.95 missing.
Build dependency gcc>2.95.3nb7: NOT found
Verifying package for ../../lang/gcc
Bootstrap dependency digest>=20010302: NOT found
Verifying package for ../../pkgtools/digest
ERROR: This package has set PKG_FAIL_REASON:
ERROR: Circular dependency detected
That is why I tried getting gcc 2.95 up and running initially.

Same thing.
I install compile tools from cd.

I know this is a boring newbie-question, but the docs are not very explicit about it: is it possible to do that afterwards or do I have to reinstall completely? If it is possible, how do I do that? The name of the tool to use would be sufficient, I could read it's docs then.

Circular dependency gone, but cant compile lang/gcc due compile error.
Yes, I ran into that on another machine that I updated to 2009Q2. Compilation of lang/gcc was stopped due to a declaration fault even after running "make clean" before.


Home | Main Index | Thread Index | Old Index