pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: gcc on i386 (NetBSD 5.0.1): circular dependency

Thomas Klausner schrieb:
On Mon, Aug 10, 2009 at 12:54:50PM +0200, Dirk H. Schulz wrote:
I have set up a new machine with NetBSD 5.0.1 (minimum installation), installed cvs as binary package and pkgsrc via cvs (2009Q2).

Now I cannot compile lots of things because of gcc 2.95 missing.

Why do you need gcc-2.95? By default it should use the gcc coming with

What do you have in your /etc/mk.conf that changes this?
I have no /etc/mk.conf so far, the machine is a fresh setup, I did not create one.

Now I have added gcc3 as binary package via pkg_add. But that does not change anything.

For example: compiling editors/nano leads to this error:
Build dependency gcc>2.95.3nb7: NOT found
Verifying package for ../../lang/gcc
Bootstrap dependency digest>=20010302: NOT found
Verifying package for ../../pkgtools/digest
ERROR: This package has set PKG_FAIL_REASON:
ERROR: Circular dependency detected

That is why I tried getting gcc 2.95 up and running initially.


Home | Main Index | Thread Index | Old Index