pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: trouble building packages. [SEC=UNCLASSIFIED]

On Thu, 4 Dec 2008, Steven M. Bellovin wrote:

> > usually when I build packages dependencies are automatically
> > built and if a previous version exists then it stops after
> > that dependency is built and asks me to delete the old version.
> > 
> > Currently I get pkgsrc complaining that some package is too 
> > old but it won't auto go ahead and build the new one! So 
> > instead of just deleting the old after the new is auto built 
> > I have to track down the new and build it myself.
> > 
> > Why is this suddenly so for me folks?
> > 
> Is it just one package or several?  In the example you quote, the
> config script wants a particular version of intltool.  But pkgsrc
> treats intltool specially, and I don't know any way to request a
> particular version via USE_TOOLS.  I think you could a a DEPENDS+= line
> for the proper version.

We had another thread about this recently (but needed 0.35.5). 

TOOLS_DEPENDS.intltool?= intltool>=0.40.0:../../textproc/intltool

Home | Main Index | Thread Index | Old Index