pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Minor problem with pango?

On Fri, 21 Nov 2008, Paul Goyette wrote:

> See my earlier posts on this subject.  I did a clean "make install" for all
> the packages, and then tried to "make package".  But "make package" tried to
> do another "make install" and failed because the package was already
> installed.

We need to figure out that problem. It works correctly for me. Here is an 

$ cd /usr/pkgsrc/textproc/o3read/
$ ls -ld work/                                                        
drwxr-xr-x  15 reed  pkgsrc  1536 Apr 14  2008 work/
$ make package
=> Bootstrap dependency digest>=20010302: found digest-20070803
===> Checking for vulnerabilities in o3read-0.0.4
===> Building binary package for o3read-0.0.4
=> Becoming ``root'' to make su-package-all (/usr/pkg/bin/sudo)
=> Creating binary package /usr/pkgsrc/packages/All/o3read-0.0.4.tgz
=> Dropping ``root'' privileges.
$ date
Fri Nov 21 12:28:47 CST 2008

> > This is done by the pango INSTALL script, which, it seems, didn't make
> > it into the pkg_taruped file.
> Should it have been included?  If so, is it an error on the part of pkg_tarup
> or something wrong in the pango package?

That also works for me.

$ pkg_tarup pango                                                      
Becoming to create a binary package
/usr/pkg/bin/sudo Creating binary package: pango-1.18.3
Creating package /tmp/pango-1.18.3
Registering depends: libXft>=2.1.10 glib2>=2.14.0 cairo>=1.2.2 
libXrender>=0.9.2 libX11>=1.1 fontconfig>=2.4.2 freetype2>=2.1.10nb1.
Registering conflicts:.
$ tar tvzf /tmp/pango-1.18.3.tgz | grep INSTALL 
-rwxr-xr-x  1 root     wheel       5010 Dec  1  2007 +INSTALL
-rwxr-xr-x  1 root     wheel       4231 Dec  1  2007 +DEINSTALL

Did you have an +INSTALL file?

Home | Main Index | Thread Index | Old Index