pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Minor problem with pango?

Following a recent upgrade of my machines to Xorg, I had to rebuild a ton of packages. Rather than rebuild them all on each separate machine, I built them once and then used pkg_tarup to create binary packages.

It seems that, for pango, there's a file missing from the resulting binary package. When I ran something that used pango, it complained about not having a pango.modules and instructed me to run

        pango-querymodules > '/usr/pkg/libdata/pango/pango.modules'

to recreate it. This worked, and isn't very hard or time-consuming, but it would seem to me that this file should have been created by the initial build of the package, and it should have been included in the binary package created by pkg_tarup, and it should have been installed when I pkd_add'ed the binary package.

Comments?  Am I missing something?  Should I file a pkgsrc PR?

|   Paul Goyette   | PGP DSS Key fingerprint: |  E-mail addresses:   |
| Customer Service | FA29 0E3B 35AF E8AE 6651 |   |
| Network Engineer | 0786 F758 55DE 53BA 7731 | |

Home | Main Index | Thread Index | Old Index