pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

libnbcompat fails to link, in bootstrap on Mac OS X 10.5.2 (x86)

I initially tried to bootstrap on a case-insensitive filesystem, with
the insensitivity flag, but that failed, with a "mkdep: gcc -isystem
/usr/include: not found" message, on linking libncompat.  I then tried
again, on a case-sensitive HFS+ disk image, and got the same behavior.
 The pkgsrc tree was checked out today.  I have the disk image mounted
on /Volumes/pkg, and /usr/pkgsrc -> /Volumes/pkg/pkgsrc and /usr/pkg
-> /Volumes/pkg/pkg.

Error summary:

===> Installing dependencies for pkg_install-20080407
===> Overriding tools for pkg_install-20080407
===> Extracting for pkg_install-20080407
===> Patching for pkg_install-20080407
===> Creating toolchain wrappers for pkg_install-20080407
===> Configuring for pkg_install-20080407
=> Configuring and building libnbcompat
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking build system type... i386-apple-darwin9.2.2
checking host system type... i386-apple-darwin9
checking whether make sets $(MAKE)... yes
checking for i386-apple-darwin9-gcc... gcc -isystem /usr/include
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc -isystem /usr/include accepts -g... yes
checking for gcc -isystem /usr/include option to accept ISO C89... none needed
checking for a BSD-compatible install...
checking whether ln -s works... yes
checking for i386-apple-darwin9-ranlib... no
checking for ranlib... ranlib
checking for gawk... /usr/bin/awk


awk -v variable=ftp_errlist -v protocol=FTP  -f
> ftperr.h
awk -v variable=http_errlist -v protocol=HTTP  -f
> httperr.h
-no-cpp-precomp -isystem /usr/include -I. -D_LARGEFILE_SOURCE
-D_LARGE_FILES -DFTP_COMBINE_CWDS fetch.c common.c ftp.c http.c file.c
mkdep: gcc -isystem /usr/include: not found
*** Error code 1

bmake: stopped in
*** Error code 1

bmake: stopped in /Volumes/pkg/pkgsrc/pkgtools/pkg_install
WARNING: *** Please consider adding c++ to USE_LANGUAGES in the
package Makefile.
WARNING: *** Please consider adding fortran to USE_LANGUAGES in the
package Makefile.
*** Error code 1

bmake: stopped in /Volumes/pkg/pkgsrc/pkgtools/pkg_install
===> exited with status 1


Home | Main Index | Thread Index | Old Index