pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg_info -E unknown error with official release and latest pkgsrc

No pkgsrc on a official release of NetBSD 4.0.

I downloaded pkgsrc.tar.bz2 (pub/NetBSD/packages/current I think). I 
asssume that is pkgsrc HEAD but no indication of that at download site.


cd pkgsrc/x11/xf86-video-intel/

I didn't want all, but it died with error about pkg_info not having -E 

I ran "make" again.

And it started building digest and dependencies for the X11 package above.

It looks like it installed pkg_install-20080313 (which has -E) but was 
still running old pkg_* tools. Next time I ran it, it used correct pkg_* 

How can we improve this?

A new user to NetBSD and to pkgsrc should not get errors like this the 
very first time used.

Also a new user would be confused because "man pkg_info" also wouldn't 
show the -E switch. How can we improve that?

And pkg_info in default path would not have -E.

What can we do to have one pkg_install installation?

Some ideas:

1) NetBSD provides pkg_install under /usr/pkg in the base set.
   (And maybe include the /var/db/pkg/ details for that too.)
   The negative to that is that pkgsrc users can no longer remove /usr/pkg
   without losing that.

2) pkgsrc overwrite pkg_* under /usr/ (not /usr/pkg). That was behaviour 
that was removed.

3) use mailwrapper(8) for pkg_* tools  but that doesn't help with manual 

  Jeremy C. Reed

Home | Main Index | Thread Index | Old Index