pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: tme and ./MY-SUN4C:8: tme/machine/sun4: No such file or directory

Quoting "Jeremy C. Reed" <>:

I am trying 4.0.

It took me a few tries to get Right-Control-F1-A to work.

Finally I got it booting.

I entered 1 after the NetBSD loaded to choose the CDROM install.

I pressed enter at next prompt to use /dev/cd0a.

And it closed and:

tmesh> Memory fault (core dumped)

No debugging symbols:

#0  0x0000000000000000 in ?? ()
#1  0x00007f7ff83058af in tme_scsi_device_target_f ()
   from /usr/pkg/lib/tme/

I haven't tried 4.0 myself.  This looks like a SCSI opcode
that I haven't emulated yet.  The SCSI emulation is poor and
just indexes an array of function pointers with the opcode -
and when the entry for an opcode is NULL it segfaults.

I tried again and this time typed in /dev/cd0a but still crashed:

This is the last thing I saw before pressing Enter:

So I tried 3.1 ISO instead and installed it and now booted into it.

I also uncommened the bpf0 line. I can't ping IP on my own host (host
running tmesh) even though I have read-write permission for /dev/bpf and
my assign le0 IP is on same network. I also assigned the mac address with
tme-sun-idprom SS2 8:0:20:BB:AA:DD >> my-sun4c-nvram.bin
and I can see that with arp -a while in my emulated sparc.

Any suggestions or examples for accessing the host system over network?

Outbound packets injected using bpf are never passed up the host's
network stack; they're just transmitted directly out the interface,
so you can't communicate with the local host.  Adding a NAT-like
network option that will use regular sockets instead of bpf is on
the list of things tme needs.

Anyone try NetBSD 4.0 with tme?

Also tme docs mention a bpf3 device.

How is that device node created? What major and minor (25 and 0)? Sorry if
I overlooked that.

Those bpf3s are documentation bugs.  It looks like multiple /dev/bpfN
devices aren't needed anymore in recent NetBSD, opening the single
/dev/bpf multiple times must work now.

Matt Fredette

Home | Main Index | Thread Index | Old Index