pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: tme and ./MY-SUN4C:8: tme/machine/sun4: No such file or directory

I am trying 4.0.

It took me a few tries to get Right-Control-F1-A to work.

Finally I got it booting.

I entered 1 after the NetBSD loaded to choose the CDROM install.

I pressed enter at next prompt to use /dev/cd0a.

And it closed and:

tmesh> Memory fault (core dumped) 

No debugging symbols:

#0  0x0000000000000000 in ?? ()
#1  0x00007f7ff83058af in tme_scsi_device_target_f ()
   from /usr/pkg/lib/tme/
#2  0x00007f7ff830604e in tme_scsi_LTX_bus_new ()
   from /usr/pkg/lib/tme/
#3  0x00007f7ff850269f in tme_ic_ncr53c9x_LTX_new ()
   from /usr/pkg/lib/tme/
#4  0x00007f7ff8502f35 in tme_ic_ncr53c9x_LTX_new ()
   from /usr/pkg/lib/tme/
#5  0x00007f7ff8700f32 in tme_ic_lsi64854_LTX_new ()
   from /usr/pkg/lib/tme/
#6  0x00007f7ff870110e in tme_ic_lsi64854_LTX_new ()
   from /usr/pkg/lib/tme/
#7  0x00007f7ffac05d1b in tme_sparc32_store ()
   from /usr/pkg/lib/tme/
#8  0x00007f7ffac06102 in tme_sparc32_st ()
   from /usr/pkg/lib/tme/
#9  0x00007f7ffac0a4e4 in tme_ic_sparc_LTX_cy7c601_new ()
   from /usr/pkg/lib/tme/
#10 0x00007f7ffac0745a in tme_sparc_new ()
   from /usr/pkg/lib/tme/
#11 0x00007f7ffda041e5 in tme_sjlj_cond_wait_yield ()
   from /usr/pkg/lib/
---Type <return> to continue, or q <return> to quit---
#12 0x00007f7ffda0423a in tme_sjlj_cond_wait_yield ()
   from /usr/pkg/lib/
#13 0x00007f7ffcf1255a in g_main_dispatch () from 
#14 0x00007f7ffcf12d3d in g_main_iterate () from 
#15 0x00007f7ffcf12f4f in g_main_run () from /usr/pkg/lib/
#16 0x00007f7ffd5a6cc1 in gtk_main () from /usr/pkg/lib/
#17 0x00007f7ffda04785 in tme_sjlj_threads_run () from 
#18 0x000000000040155d in ?? ()
#19 0x000000000040109f in ?? ()
#20 0x00007f7ffdffa000 in ?? ()
#21 0x0000000000000002 in ?? ()
#22 0x00007f7ffffff9e0 in ?? ()
#23 0x00007f7ffffff9e6 in ?? ()
#24 0x0000000000000000 in ?? ()

I tried again and this time typed in /dev/cd0a but still crashed:

This is the last thing I saw before pressing Enter:

So I tried 3.1 ISO instead and installed it and now booted into it.

I also uncommened the bpf0 line. I can't ping IP on my own host (host 
running tmesh) even though I have read-write permission for /dev/bpf and 
my assign le0 IP is on same network. I also assigned the mac address with  
tme-sun-idprom SS2 8:0:20:BB:AA:DD >> my-sun4c-nvram.bin
and I can see that with arp -a while in my emulated sparc.

Any suggestions or examples for accessing the host system over network?

Anyone try NetBSD 4.0 with tme?

Also tme docs mention a bpf3 device.

How is that device node created? What major and minor (25 and 0)? Sorry if 
I overlooked that.

Home | Main Index | Thread Index | Old Index