pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: python24 - Unlocking unlocked mutex

On Monday 10 March 2008 12:24:09 Greg Troxel wrote:
>   I'm seeing the following when starting an application that uses python
>   python2.4: Error detected by libpthread: Unlocking unlocked mutex.
>   Detected by file "/opt/src/lib/libpthread/pthread_mutex.c", line 412,
>   function "pthread__mutex_unlock_slow".
>   I had to export PTHREAD_DIAGASSERT=A in order to stop it from dumping
> core. Is this a known problem with python?
> I have seen this with pyscopg, but not python itself.  Does your program
> use any modules?

I think so, the program is wip/sonata, the Makefile includes the following


I ran gdb on the core file:

Core was generated by `python2.4'.
Program terminated with signal 6, Aborted.
#0  0x401891b8 in pthread__errorfunc () from /usr/lib/
(gdb) where
#0  0x401891b8 in pthread__errorfunc () from /usr/lib/
#1  0x40187400 in pthread_mutex_held_np () from /usr/lib/
#2  0x41359098 in gdk_threads_leave () from /opt/pkg/lib/
#3  0x410f2a24 in gtk_main () from /opt/pkg/lib/
#4  0x40eb8d8c in init_gtk ()
   from /opt/pkg/lib/python2.4/site-packages/gtk-2.0/gtk/
#5  0x400ecbb8 in PyEval_EvalFrame () from /opt/pkg/lib/
#6  0x400ecf88 in PyEval_EvalFrame () from /opt/pkg/lib/
#7  0x400eede8 in PyEval_EvalCodeEx () from /opt/pkg/lib/
#8  0x400eef1c in PyEval_EvalCode () from /opt/pkg/lib/
#9  0x40109c68 in Py_CompileString () from /opt/pkg/lib/
#10 0x40109c68 in Py_CompileString () from /opt/pkg/lib/
Previous frame identical to this frame (corrupt stack?)
(gdb) quit

Looks like it's py-gtk2 that has this bug, though I haven't tried running any 
other GTK applications, I mainly run KDE stuff. Is it possible for the bug to 
be in GTK?

Home | Main Index | Thread Index | Old Index