pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

clisp pkgsrc-current mit-clx error

Greetings all,
  I've been trying to build clisp with clx support,
in order to do this I tried the pkgsrc-current branch
(which I just downloaded fromp March 10th 2008)
of pkgsrc since clisp in that version has an
file to support passing PKG_OPTIONS.clisp=mit-clx to clisp.

The problem is that when I try to 'make' clisp with the above
option, it errors out saying:

"./configure: invalid argument --x-includes=/usr/X11R6/include
./configure: Try './configure --help'

The exact error message transcript is attached in error-unix.txt

I tried the same thing in wip/clisp-current and I had the same error message.

Does anyone know why this happending and how to fix this and/or any workarounds?

Thank you in advance to anyone who can shed some light on this.
Script started on Mon Mar 10 23:09:34 2008
Amnesiac# make PKG_OPTIONS.clisp=mit-clx
=> Bootstrap dependency digest>=20010302: found digest-20060826
===> Skipping vulnerability checks.
WARNING: No /var/db/pkg/pkg-vulnerabilities file found.
WARNING: To fix run: `/usr/pkg/sbin/download-vulnerability-list'.
===> Configuring for clisp-2.44.1
=> Modifying GNU configure scripts to avoid --recheck
=> Replacing config-guess with pkgsrc versions
=> Replacing config-sub with pkgsrc versions
=> Replacing install-sh with pkgsrc version
sh: Illegal option --
./configure: invalid argument --x-includes=/usr/X11R6/include
./configure: Try `./configure --help'
*** Error code 1

make: stopped in /usr/pkgsrc/lang/clisp
*** Error code 1

make: stopped in /usr/pkgsrc/lang/clisp
Amnesiac# exit
Script done on Mon Mar 10 23:09:58 2008

Home | Main Index | Thread Index | Old Index