pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: spcaview, QuickCam Chat

Hello Martijn,

  MvB> Try gmake. Many auto-generated makefiles are GNUified these
     > days.

gmake did much the same thing.

I tried following the instructions again at Mizuno Takafumi's site,
with a little more success.  This time I actually got as far as cc
trying to compile the thing.  It said...

    cc -O2 -Wall -g   -Werror    -c spcadecoder.c
    cc1: warnings being treated as errors
    spcadecoder.c: In function `fun_D':
    spcadecoder.c:739: warning: value computed is not used
    spcadecoder.c: In function `make_jpeg':
    spcadecoder.c:3993: parse error before `*'
    spcadecoder.c:3996: `start' undeclared (first use in this
    spcadecoder.c:3996: (Each undeclared identifier is reported only
    spcadecoder.c:3996: for each function it appears in.)
    spcadecoder.c:4013: `i' undeclared (first use in this function)
    spcadecoder.c:4014: `value' undeclared (first use in this
    *** Error code 1

    make: stopped in /home/ball/camfix/spca5xx-20060101/drivers/usb
    *** Error code 1

    make: stopped in /home/ball/camfix/spca5xx-20060101/drivers/usb

Perhaps I need a way to ask it not to treat warnings as errors.  Then
again, perhaps the C source needs fixing.  Sadly my C skills are rusty
enough to be considered missing. Since this isn't the pkgsrc version I
should probably mention it to TakaM, who I believe took the Linux
version and ported it to NetBSD.  I don't know if he's maintainer of
graphics/spcaview though, and I don't have an email address for him.

- Andy Ball.

Home | Main Index | Thread Index | Old Index