NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD 9.1 amd64, base X11: garbled display

On Sat, 10 Apr 2021, Rhialto wrote:

> I have a laptop of about 10 years old with an Intel "GM45"(?) chipset
> (or i965 is mentioned in some places).

I have a G41 chipset in my primary workstation machine and I see
frequent references to i965 for dri-related things (and that the
i965 vdpau module is not present in NetBSD's Xorg/OpenGL--as noted
by mplayer, mpv, vlc, etc.).

> It worked fine up to NetBSD 8.x. But now on 9.1, if I run x64 (from
> package emulators/vice) on it for a while I get errors in my xterm
> "i965: Failed to submit batchbuffer: Input/output error",
> and the kernel crashes sometimes a short time later.

I've seen/experienced these as well, mostly when trying to play videos
through firefox (firefox52, actually).  IIRC, the workaround has been
to set "LIBGL_ALWAYS_INDIRECT=1".  I do it in a wrapper script for
firefox, but if other things trigger it, perhaps it should be set/exported
in .xsession (or other display-manager session configuration/startup file).
> The config file is mostly the auto-detected stuff, enhanced with some
> preferences from my previous xorg.conf file. For some reason, 2 cards
> were detected, Card0 and Card1 and I just copied that, just in case it
> is important.
> 000:02:0: Intel 82GM45 Integrated Graphics Device (VGA display, revision 0x07) [i915drmkms0]
> 000:02:1: Intel 82GM45 Integrated Graphics Device (miscellaneous display, revision 0x07)

Function 0, according to the device ID reported in your Xorg.0.log and
matched in "i915pciids.h" is a GM45_G.  You said it's a laptop, so I
suppose it's the "Mobile" variant of the G45.  Function 1 is not listed.
I wonder what "miscellaneous display" means?

Before the gen 3/4/5 chips were defaulted to UXA, the only xorg.conf
I needed was to set AccelMethod UXA.  Since the default to UXA, the
auto-detection works properly and I don't need xorg.conf anymore.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]consolidated[flyspeck]net  OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index