NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Installing NetBSD 9.1 on USB stick, not booting

Hi Mayuresh,

I recently set up a NetBSD 9.1 for my NAS with BIOS boot in the same way. My problem was that both the installer USB stick and the target USB stick for the installation were connected at the same time during the installation (logical ;-)). During the installation, the target USB stick was detected as unit sd1, and the installer as sd0. When booting without the installer after the installation, the target USB stick then takes the place of the installer USB stick and becomes sd0 itself. As a result, the root filesystem could not be mounted because the entry in fstab was still set to sd1. Since then I mount the target partition again r/w before the first reboot and correct the fstab if necessary. I don't know if this helps you. As partitioning scheme I used disklabel. In this case at least the bootloader was installed. I did not try with GPT.

Many greetings

On 05.04.21 19:36, Mayuresh wrote:
I have installed NetBSD 9.1 on a USB stick. I think earlier installers
used to ask about bootcode. 9.1 installer didn't ask me about it. The
installation seems fine but the stick is not booting.

I tried manually setting the boot manager (fdisk -B) though it didn't
work. I do not have a trace of all my attempts but finally it rendered the
USB stick read-only. Wasn't able to make it writable again, also tried on

I got a new replacement stick now and I am back into the same situation -
installation is complete, but it won't boot. What exactly do I need to do
to make it bootable. I don't need it to work with the hdd of the host or
grub etc. Just need plain simple bootable usb stick that would boot into

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Home | Main Index | Thread Index | Old Index