NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Printing and CUPS

I’m running NetBSD 9 and I can build from source. 

I tried to build cups-base but it did not end well, I got errors and tried to fix them , for example , it could not find liquuid but I made rather a mess of things.   So, I’m starting again with a fresh install of NetBSD 9.0 and I’ll use pksrc to build cups-base.  Am I right in assuming that I should not mix pkgin with pkgsrc?


On 17 Oct 2020, at 2:38 am, Patrick Welche <> wrote:

On Thu, Oct 15, 2020 at 03:12:23PM +1100, Glenn Mawby wrote:
Glenn Mawby <>
14:43 (28 minutes ago)
to majordomo
I've installed NetBSD 9 on intel based machine and I'm having trouble
setting up printing. I decided to use CUPS to manage printing.   The
printer is on my local network and has a fixed IP address.

I installed cups and hplip, enabled and started cupsd, and added the HP
OfficeJet 8610 to CUPS.

When I print the test page the job is visible in the queue and completes
but nothing prints.   If I look in /var/log/cups/error_log I see the
following error.

E [14/Oct/2020:20:06:47 +1100] [CGI] Unable to execute ippfind utility: No
such file or directory

I checked the wiki and followed the instructions setting up CUPS and as far
as I can tell I've done everything right.  I also see chatter on some Linux
forums describing a similar problem.

Is there another package I'm supposed to install to make this work?


I just committed the movement of the comma, so cups-base-2.3.3nb7 should
come with ippfind by default. Not sure if it will fix your printing,
but at least that error would disappear. (ippfind needs mdnsd=YES in
/etc/rc.conf in that case)

Can you build packages from pkgsrc?
What version of NetBSD are you running?



Home | Main Index | Thread Index | Old Index