NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Unusable Realtek NIC after upgrading to NetBSD 9

Rocky Hotas <> wrote:

> Using NetBSD 8.1 in a laptop, both its Ethernet and WiFi NICs worked.
> Then, I made a NetBSD 9 (formal release) fresh install and the
> Ethernet NIC is almost unusable.
> Here, the relevant dmesg part:
> [     1.055234] re0 at pci3 dev 0 function 0: RealTek
> 8100E/8101E/8102E/8102EL PCIe 10/100BaseTX (rev. 0x05)
> [     1.055234] re0: interrupting at msix3 vec 0
> [     1.055234] re0: Ethernet address 28:92:4a:29:53:5a
> [     1.055234] re0: using 256 tx descriptors
> [     1.055234] rlphy0 at re0 phy 7: RTL8201E 10/100 media interface,
> rev. 2
> [     1.055234] rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX,
> auto
> The card is detected and configured by the system, but it is extremely
> slow: a Google ping may take up to 10 seconds (yes, 10000 ms). An ssh
> connection is extremely slow, making it unusable.
> It seems that, if I use the card, the dmesg gets populated by this
> repeated message:
> [ 20690.751223] re0: watchdog timeout
> [ 20695.773292] re0: watchdog timeout
> [ 20706.809817] re0: watchdog timeout
> [ 20720.853570] re0: watchdog timeout
> [ 20730.887686] re0: watchdog timeout
> I also tried to boot disabling rlphy(4) (`userconf disable rlphy' from
> the boot prompt), and ukphy(4) is used instead, but nothing changed.
> The same happens with netbsd-9 (stable).
> This problem did not appear with NetBSD 8.1, so it is a regression.
> Is there anything I can do?

Data point.  I had something that looked similar enough to this with
my USL-5p (landisk)

re0 at pci0 dev 0 function 0: RealTek 8139C+ 10/100BaseTX (rev. 0x20)
re0: interrupting at irq 5
re0: Ethernet address 00:a0:b0:65:15:6c
re0: using 64 tx descriptors
rlphy0 at re0 phy 0: Realtek internal PHY
rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto

It was mostly sitting idle then one day it popped this watchdog
timeout and lost its network iirc.

Next time I powered it on it failed to boot b/c it runs with nfs root
and it had that watchdog timeout right from the start.  As far as I
can tell the relevant kernel versions were 8.99.12 and 8.99.36

I recently booted current on that machine (moved to a different
network) and it did work.

So, I'd try with booting a current'ish kernel on your machine.  Enough
compat is enabled by default in GENERIC, so you can just drop in
current as and boot it one off manually with the existing
9.0 install.


Home | Main Index | Thread Index | Old Index