NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Trouble installing NetBSD 9.0 amd64


I still have to try stepping through your install script to try to fix my install. I have been using the NetBSD 9.0 image since about end of March (when New Zealand Carona lock down started). I was excited because it mentioned the UEFI support.

I used the three NetBSD installation guides because I was having trouble installing it easily and I was getting further along with the help of those guides.

Yes it has had previous UEFI installs on it in this order, Windows 8 (It's a 2012 laptop), Ubuntu (As it had UEFI support), Lubuntu (Ubuntu but lightweight also with UEFI support) and finally attempted NetBSD. I think I tried installing FreeBSD on it but it didn't come with X (twm) as standard, but I think that booted so I went back to Lubuntu ?!?!.

I've tried installing NetBSD 9.0 to another USB stick and on reboot that USB stick is not bootable.

I could try the lubuntu option and modify it's boot loader to add NetBSD to the boot menu.
I could resize the NetBSD 9.0 partitions or add new ones on the USB install stick and modify the /etc/fstab as then I would have a bootable NetBSD 9.0. I find USB 3.0 fast enough as well for my needs.

I find the setting up NetBSD to install from a USB stick guide, not the most friendiest tutorial.

So I can set up and format the wedges, extract the packages, add users, copy the efi files to the msdos partition. I'm quite far along, It's just doing the part that makes it bootable like the USB install image.
But first I need to work through your script.


On Wednesday, 20 May 2020, 23:35:51 GMT+12, Robert Nestor <> wrote:

Reading this thread it appears to me Ahi was booting up from NetBSD 8.0 on a USB stick and then trying to install 9.0 on his hard drive.  I’m not sure, but that could be part of his problem.  I seem to recall running into problems with GPT partitioning and UEFI booting when I tried doing this some time ago.  The second problem would be running the Installer in this setup as it isn’t clear which version of the Installer he’s running, the 8.0 one or the 9.0 one.  Third was trying to follow installation instructions from sources other than the NetBSD guides and Wiki from the NetBSD site.  I’ve suggested he download the 9.0 USB image and try using it to install 9.0.

On the issue of his system going back to the BIOS screen even after setting up the system for UEFI booting, there are at least two possibilities I’ve seen on my system.  First, if the firmware is configured to prefer BIOS booting over UEFI or if the UEIF booting is disabled in the firmware this can happen.  Second, he states he had GPT partitions on the disk previously so I’d assume he had a UEFI bootable system installed at some point.  If that was Windows or almost any version of Linux those installations would have set the UEFI variables for booting such as which system to boot.  If those variables no longer apply to the setup on his newly installed system the UEFI boot will most likely fail and fall back to a BIOS boot.

The UEFI variables are normally managed by a utility such as efibootmgr which doesn’t exist (yet) in NetBSD though.  So getting rid of them or reconfiguring them can be a problem.  In my system I can boot into the BIOS to manage boot sources, enable/disable UEFI booting and also reset the firmware.  Resetting the firmware removes all the currently defined UEFI variables.  I’ve also managed the UEFI boot variables by booting up a Linux CDROM and running its efibootmgr.  However, to do this the CDROM has to be booted up via UEFI; booting it up via BIOS doesn’t load the components necessary to run efibootmgr.

Home | Main Index | Thread Index | Old Index