NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: library cleanup after a system upgrade

> On May 9, 2020, at 5:21 AM, Riccardo Mottola <> wrote:
> Hi All!
> Christos Zoulas wrote:
>>> ..and then it usually turns out that I forgot to recompile any
>>> local programs that still needed them :)
>> /usr/src/lib/checkoldver /usr/lib | xargs rm -f
> that was it! yes! It helped clean up my tight /usr partition, but not enough

You can to it in /lib and /usr/X11R7/lib :-)
> Everything got quite fatter - I had 6 + packages, no issue. Then
> upgraded to 7, refreshed packages.. it worked. Tried to upgrade to 8.2
> .. and I was not able to finish unpacking.
> The reason of this crap is because I wanted a small / to boot (kernel
> position limits of the boot loader), so I did a just 1G / and 1G /usr
> and he "rest" of the hefty 4G disk to /home...
> Anyway, I was stubborn and found in the pile of HDDs one that worked in
> the SS10...  An old 1GB disk worked enough to breath and finish NetBSD
> 8.2 install!
> Machine is running fine now! Yay!
> now... well the only issue is that important packages are missing binary
> for 8.2... I was not able to update them all, but this is a separate
> issue. And we have a separate thread for that.

Just ln -s to Most of the time things work :-)

> Thanks,
> Riccardo

Attachment: signature.asc
Description: Message signed with OpenPGP

Home | Main Index | Thread Index | Old Index