NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NVMM not working, NetBSD 9x amd64

I'm not subscribed to this list but someone forwarded me your email:

> I'm curious about the situation on the NVMM front. On its page it says
> that it works both with Intel and AMD cpu's
> (, but I've
> read elsewhere (
> that it only works on AMD - so who is right?

The oldest one is the "wrong" one: the blog post here was written when NVMM had
just been developed, and at first it had only AMD support. Quickly after it
gained Intel support. So now, it has Intel support.

> 1. I tried it on my PC, but it didn't work. My CPU is Intel(R)
> Core(TM)2 Duo CPU T9600, Vt-x enabled.
> First I used the NetBSD 9.0 amd64 release version:
> [...]
> localhost# modload -f nvmm
> modload: nvmm: Not supported
> Apr 25 14:55:11 localhost /netbsd: [ 1781.0615600] [!] No implementation found
> Apr 25 14:55:11 localhost /netbsd: [ 1781.0615600] WARNING: module
> error: built-in module nvmm failed its MODULE_CMD_INIT, error 86

As the message indicates, your CPU is not supported. T9600 is from 2008, and
even though it has VT-x, it probably doesn't have EPT, which means it doesn't
support "real" hardware virtualization. So you cannot use NVMM on your CPU.
There are several hypervisors you also won't be able to use, this CPU is just
too old.

Maybe I should add a note in the man page to say that you cannot expect a CPU
from before ~2010 to have virtualization support.

> 2. Also I've got a question about qemu. The 'vanilla' qemu from pkgsrc
> (that is recommended on the m00nbsd page) doesn't know the accelerator
> 'nvmm'.
> localhost$ qemu-system-x86_64 -hda ubuntu.qcow -cdrom
> /mnt/ubuntu-16.04.4-desktop-amd64.iso -m 1024M -accel nvmm
> qemu-system-x86_64: -machine accel=nvmm: No accelerator found
> Qemu-nvmm is deleted from pkgsrc/wip at the moment:

Maybe you're using an old branch of pkgsrc? The NVMM accelerator is in the
"recent" branches of pkgsrc.

However this won't help you because your CPU is too old.

> 3. Trying the nvmmctl utility ('nvmmctl identify' and 'nvmmctl list')
> results in panic and following reboot after a long count, see
> screenshots for output:
> (Of course 2. and 3. refer to a situation without the nvmm module loaded)

That was a bug, caused by an initialization problem that you managed to
trigger with your configuration. I have now fixed it:

It will be applied to NetBSD-9 soon, so within a few days you should not
have this bug anymore. Thanks for the report!


Home | Main Index | Thread Index | Old Index