NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Looking for java an android devs on netbsd environment

On 07/04/2020 08:17, John m0t wrote:

On my previous NetBSD 9.0 install, I pkgin all the full suse emulation package(s) and I managed to even run idea-IU-193.6911.18 with its own JBR version. (man the font rendering was awesome there). but the same error was present there too. the IDEA can't even compile simple hello world. with that the same error)

I ran into a similar (but not the same) problem when doing certain things with jenkins on openjdk8. That error looks like its wanting a native binding for a particular API set.

In my case I was able to find a patch in FreeBSD pkgsrc that resolved the problem and with a bit of help from one of the pkgsrc developers got it applied to the NetBSD JDK package. The FreeBSD patches tend to get upstreamed as the versions move forward so you may have to look in their revision history to find the relevent patch.


Home | Main Index | Thread Index | Old Index