NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: iscsi initiator troubles [SOLVED]

I started noticing weird symptoms when increasing the MTU on the secondary 
(iscsi) ethernet ports on the three systems - could not get a stable 
environment unless using MTU of around 3100 or smaller. That led me to suspect 
that the cheapie Realtek gig-E cards and/or RE driver that were common to the 
two netbsd systems was the culprit. 

I replaced with three low-end Intel CT desktop adapters. Now, 9K MTU works, and 
iscsi-initiator against iscsi_target now works well. I am having problems with 
iscsi-initiator against istgt, but have not tried the most current versions 
yet, and heard there may have been some patches since 2/2011. 

----- Original Message -----

From: "Chavdar Ivanov" <> 
To: "Manuel Bouyer" <> 
Cc: "John Jaser" <>, 
Sent: Thursday, September 29, 2011 5:27:13 AM 
Subject: Re: iscsi initiator troubles 

On 29 September 2011 09:20, Manuel Bouyer <> 
> On Wed, Sep 28, 2011 at 05:56:19PM -0400, John Jaser wrote: 
>> Manuel: 
>> Using the 5.1-generic kernel, i reproduced the hang. 'top' stayed running 
>> and is posted below. The free mem started at about 7500MB before the first 
>> file copy, and remained at about 6500- 6900MB as seen below: 
> OK, so it's not the issue manu@ ran into when playing with glusterfs. 
> Sorry, no more idea ... 

Sorry if that would be sounding negative, but - using various versions 
of -current, both i386 and amd64 - I've had difficult to trace 
problems with the built-in iscsi-target on NetBSD - like core dumps 
when the Windows 2008 R2 serve initiator system reboots; hence I've 
given up at this stage using it and switched all my NetBSD targets to 
using pkgsrc/istgt - with no problems whatsoever. 

> -- 
> Manuel Bouyer <> 
> NetBSD: 26 ans d'experience feront toujours la difference 
> -- 


Chavdar Ivanov 

Home | Main Index | Thread Index | Old Index