NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Xorg compilation issues - source update question


I'm using NetBSD 5-something and currently building from source fails on dri2proto in external/mit/xorg/include with "nmbmake : Don't know how to make dri2proto.h". I googled around and this led me to believe that it's stale dependencies, so I cleared out /usr/obj and /usr/tools and tried again, with the same results. I suspected that maybe my source trees was somehow corrupt so I removed the contents of external/mit/xorg, updated the sources again and tried to build, with the same results.

The command I use to build is :

cd /usr/src
./ -O ../obj -T ../tools -U distribution

In /etc/mk.conf I explicitly declare MKX11=YES, X11_TYPE=modular, and X11FLAVOUR=Xorg.

and to update the sources I use

cvs -q update -Pd -r netbsd-5

Am I right in thinking that cvs command will get me the latest version of NetBSD 5 (rather than, say, getting me 5.0.1)?

This is driving me bananas, doubly so because I'm convinced that it's something dumb on my part. Any ideas to put me out of my misery would be much appreciated.

Best regards,


__________ Information from ESET NOD32 Antivirus, version of virus signature 
database 4817 (20100129) __________

The message was checked by ESET NOD32 Antivirus.

Home | Main Index | Thread Index | Old Index