NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

cgd newfs problem

Dear NetBSD users,

In my endeavours to make NetBSD my main OS, I tried to set up the CGD 
encryption method. Specifically, as I am still testing it, I did not wish to 
dedicate an entire partition to it, but tried to make a file and use vnd. 
Unfortunately, I cannot do a newfs on the file.

In my last try I tried to follow the instructions by Hubert Feyrer:

and that is the part where I get a failure message:

# cgdconfig -V re-enter cgd0 /dev/vnd0a $base.cgd
     /dev/vnd0a's passphrase:
     re-enter device's passphrase:
# newfs /dev/cgd0a

The cgdconfig command executes just fine and asks me for my passphrase. But 
then, when I try to execute newfs, I just get a message "device busy". Do I do 
something wrong? Or should I do something different? - I DID first create the 
vnd device, and then on top of it I did cgdconfig, so I do not understand why 
newfs refuses to function.

Your kind help will be highly appreciated.

Kind regards,


Neu: GMX Doppel-FLAT mit Internet-Flatrate + Telefon-Flatrate
für nur 19,99 Euro/mtl.!*

Home | Main Index | Thread Index | Old Index