NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: problems using NetBSD as accesspoint with non-netbsd clients

On Mon, 22 Jun 2009 10:33:59 +0200
David Wetzel <> wrote:

> does somebody use netbsd 5 (ath) as AP and uses clients like Nokia  
> phones or Macs?

I am using a netbsd 4.0 system as an access point with an atheros driver:

        ssid NETAPPS apbridge
        powersave off
        bssid 00:15:e9:a7:e8:fd chan 1
        address: 00:15:e9:a7:e8:fd
        media: IEEE802.11 autoselect mode 11g hostap
        status: active
        inet netmask 0xffffff00 broadcast
        inet6 fe80::215:e9ff:fea7:e8fd%ath0 prefixlen 64 scopeid 0x1

> On my mac, I do have connectivity, everything is fine until the  
> antenna logo still shows all bars but I cannot reach the internet.
> If I disable/enable the wlan on the mac it works again.
> The Nokia stops being able to register on SIP the only thing that  
> seems to help is to restart hostapd.

My normal client machines use ubuntu linux. But visitors have connected to it 
with windows laptops. My nephew uses it with his ipod touch. The wii gets 
online okay. I don't think we have tried a mac but I wouldn't have expected any 
problems. Haven't tried a nokia phone either.

I don't know what hostapd is. I just use ath0 as a normal network interface. I 
run NAT to route traffic to my external gateway. The AP uses dhcrelay to 
provide DHCP services to the wireless network.

Can you get some diagnostic information from the mac? On linux I would tail -f 
Michael Smith
Network Applications   | +61 (0) 416 062 898
Web Hosting          | Internet Services

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index