NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD 4.0, amd64 SMP, weird corruption issues

Mark Cullen wrote:
Christos Zoulas wrote:
In article <g50koo$fp0$>,
Mark Cullen  <> wrote:
Hi there,

I'm in the process of updating my small home server with a nice new machine. I've downloaded the amd64 version of NetBSD 4.0 to install.

Here's the more important machine specs:

Intel 2180
Gigabyte G31M-S2l with latest BIOS
2 x 1024MB Corsair PC6400 5-5-5-12
Seasonic 330W PSU

It's installed fine, and everything seems to be working lovely. Even the onboard Realtek NIC. I've set up one of the RAID-1's with RAIDframe and that's looking good. I had just got the latest pkgsrc and was trying to install some bits and bobs, and that's where it appears to have gone downhill.

Here's what happens if I try and update my pkgsrc tree. The following screenshot had just started to update files, and was listing changes and stuff.

If I right click the PuTTY title bar and 'reset terminal', it springs back to life again and everything is readable as normal! However, some Makefiles and such in pkgsrc are garbled binary too. It seems like some kind of network corruption issue to me? I've tried switching to a good old fashioned reliable Intel PCI NIC, and have the same results. In fact, that screen shot was captured when using the Intel NIC.

Any thoughts? Have there been any known issues with network corruption reported?

Looks like something is typing CTRL-O [enter ALT-GR1]. You can undo
this by echo CTRL-N to your terminal. Can you capture the output of cvs
update to the file?


Hi Christos

I tried just now, and ran it once to make sure it was still doing it. I was then writing some stuff in a script in vi. I exited vi, and the shell prompt had become garbled. Perhaps CVS is triggering the bug somehow, I don't know.

I am not sure CVS just outputting a CTRL-O somewhere would be causing files to be corrupt either? Some Makefiles that CVS has downloaded are garbled binary.

Hm. This install is on a temporary Deathstar disk. Maybe it's just that on it's way out, written some junk to the disk, CVS reads junk back and it all goes bananas?

I've got a Seagate on RMA that I am intending to do the proper install on. I was just doing this to set things up and make sure it all works OK.....!

I'll let you know if a new disk fixes things, but if anyone has any other ideas in the mean time, or needs more info, just ask :)

Ok, a small update.

First I deleted pkgsrc from the Deathstar disk and tried to fetch it again. That seemed to go OK, though I didn't finish the fetch. With the CVS update the garbage happened pretty quickly though.

I then symlinked pkgsrc to the raid1 disks and have just now done a CVS fetch / update, and that issues appears to have disappeared.

I think, or should I say hope, that it's just the Deathstar disk on the way out. I don't even know if it's possible for a hard disk to "pretend" to write to sectors, and the data sort of just doesn't actually get written. Complete guesswork. If it's that, I'm not fussed because I won't be using that disk for long anyway. If it's not that and some other very rare bug.... not so good!

I'll continue testing, and if it happens while pkgsrc is on the raid1 I will post back.

Best Regards,
Mark Cullen <>

Home | Main Index | Thread Index | Old Index