NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Fwd: PLEASE HELP! mail not working :(

Dear all,

I hate to say it, but e-mail is actually NOT working. I can GET e-mails - but 
how do I SEND them?

In my .muttrc the line

set sendmail="/usr/sbin/postfix -U -P 
mysecretpassword -d -f"

does not work.

NetBSD complains that postfix is reserved for the superuser and that it does 
not know the options -U and -P.

What line should I use instead?

Thank you in advance for your kind help.

As a general comment - indeed I am angry, so if this is opinionated, please 
forgive me - I think this situation is totally inacceptable. I want to evaluate 
NetBSD SERIOUSLY, and with a friend we are time and again giving it a shot. And 
we fail EVERY TIME! We are inexperienced, but by far not stupid. - When I look 
at the Ubuntu guides, they actually WORK. There is a series of commands, they 
are explained - if you care, understand them, if you don't, just issue them, it 
will WORK. When I look at the NetBSD guide, it actually DOESN'T. Not only is 
NetBSD a more complicated system to set up, it is also not documented 
appropriately. The idea of documentation - in my eyes - is not "half-truths for 
those who know how to do it already", but actually to let someone DO something 
who has NEVER done it, and easily. With all due respect, even MS-DOS has a 
better documentation. Yes, less features, but at least you know what to do with 
them. It is hard to defend that "BSDs are better documen
 ted" when their documentation is not _accurate_. (I am criticising BSDs, 
because I used to have a higher opinion of them - but now FreeBSD 7.0 has no 
OpenOffice packages, and FreeBSD 6.3's window system is bugged, as 6.2 works 
fine for me.) Even more surprising were the packages on the NetBSD 4.0 Install 
CD - instead of a collection of small tools for kind of everything you might 
need, there are scads of KDE, but almost everything I was looking for was 
_missing_. If I use the bloat of KDE, and I actually LIKE it, then I am using 
it on LINUX which has the HARDWARE SUPPORT (syncing mobile phones on NetBSD 
anyone?). And KDE with all extras which make life pleasant will then need MORE 
than one CD. On Linux KDE makes sense, as Linux is a bit "big" anyway. When I 
want a lean system with all packages people use every day (writing documents, 
converting documents into different formats [including Microsoft's], playing 
media, surfing the internet, sending and receiving e-mails, chatti
 ng at least through ICQ & MSN) - then I am thinking of NetBSD, but maybe I am 
wrong. Right now, I am trying very hard - but somehow, I am getting more and 
more the idea that NetBSD is just a total time-waster, given that Damn Small 
Linux & friends exist as well.

I must say, what applies to NetBSD does not apply to its users, so thank you 
very much for your kind support. You guys are the reason why I actually don't 
give it up.

Oh, by the way, did I also mention that xedit doesn't work? (The default editor 
in x; it cannot load or write files.)


Kind regards,


_________________________Previous discussion below_________________

Dear Tonnerre,

Thank you so much, now it works! :))

(Indeed, my name is actually Nino...)

-------- Original-Nachricht --------
> Datum: Sat, 7 Jun 2008 21:38:01 +0200
> Von: Tonnerre Lombard <>
> An: "netbsd unix" <>
> CC:
> Betreff: Re: PLEASE HELP! mail not working :(

> Salut, netbsd (WTF?),
> On Sat, 07 Jun 2008 20:37:16 +0200, netbsd unix wrote:
> > I am getting repeatedly a "smtp connection refused" error when I try
> > to run fetchmail. telnet localhost 25 does not work either.
> Please edit your /etc/postfix/ and enable the SMTP service and
> soon it will work magically.
>                 Tonnerre


-------- Original-Nachricht --------
Datum: Sat, 07 Jun 2008 20:37:16 +0200
Von: "netbsd unix" <>
Betreff: PLEASE HELP! mail not working :(

-------- Original-Nachricht --------
Datum: Sat, 07 Jun 2008 20:34:34 +0200
Von: "netbsd unix" <>
Betreff: PLEASE HELP! mail not working :(

Dear people,

With all due respect, after all these hours, I am getting quite fed up with 
NetBSD's mail system... on the other hand, I am not very experienced.

I once already had a discussion here about setting up e-mail, and after 
numerous hours, it finally worked; I wrote a short summary, and when I tried 
it... it DIDN'T work.

I am getting repeatedly a "smtp connection refused" error when I try to run 
fetchmail. telnet localhost 25 does not work either.

What I did so far:

The machine is connected to an internal network (in this case, of a dormitory) 
which, by DHCP, assigns the IP address to the machine. This happens 
every time the machine connects. How you find the ip-address, assuming your 
network card is ex0: ipconfig ex0. You are not being assigned anything else 
than this IP address. (No network name or similar).

You have the username "thatsme" (with the password "mypass", this password is 
not important here) on your local machine - let us call it as hostname, and as domain. Your mail 
provider is, with and used to send 
and receive mails; your username there is "", and 
password is "mymailpass".

What I did so far is:

in /etc/rc.conf write:


in /etc/hosts write: localhost -- whether it is this or does not make a 
difference, later on it just fails with if I leave the original value.

in /etc/postfix/ write:
myhostname =
mydomain =
mynetworks_style = host
relayhost =
smtp_generic = hash:/etc/postfix/generic

in /etc/postfix/generic write:

then issue the following commands:
# postmap /etc/postfix/generic && postfix check && /etc/rc.d/postfix reload'
$ date | mail -s TEST

Indeed, I got an e-mail with the date.

I use fetchmail, and in .fetchmailrc I wrote

poll protocol pop3 user "" password 

since .fetchmailrc must not have more rights that -rwx--x---, I set the rights 
with chmod as user thatsme:

chmod u=rwx,g=x,o= .fetchmailrc

now, I should be able to send and receive e-mails.

But when I now say

$ fetchmail -v

I see it successfully connects to, SEES that there are two 
e-mails, and is totally unable to actually GET them:
Trying to connect to failed
fetchmail: connection to localhost:smtp [] failed: Connection 
fetchmail: SMTP connect to localhost failed

PLEASE HELP! What's the matter with this?!

Kind regards,

GMX startet Hier findest Du Leute mit Deinen Interessen!
Jetzt dabei sein:

Psssst! Schon vom neuen GMX MultiMessenger gehört?
Der kann`s mit allen:

GMX startet Hier findest Du Leute mit Deinen Interessen!
Jetzt dabei sein:

Home | Main Index | Thread Index | Old Index