Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

race condition in kerberos?


Yesterday I did two builds from the same source tree - two because the first one failed:

--- includes-crypto/external ---
*** Failed target: /usr/obj/amd64.gcc.20240613/usr/include/krb5/ocsp_asn1.h
*** In directory: /usr/src/crypto/external/bsd/heimdal/lib/libhx509
*** Failed commands:
        @cmp -s ${.ALLSRC} ${.TARGET} > /dev/null 2>&1 ||  (${_MKSHMSG_INSTALL} ${.TARGET};  ${_MKSHECHO} "${INSTALL_FILE} -o ${BINOWN} -g ${BINGRP}  -m ${NONBINMODE} ${.ALLSRC} ${.TARGET}" &&  ${INSTALL_FILE} -o ${BINOWN} -g ${BINGRP}  -m ${NONBINMODE} ${.ALLSRC} ${.TARGET})
        => @cmp -s ocsp_asn1.h /usr/obj/amd64.gcc.20240613/usr/include/krb5/ocsp_asn1.h > /dev/null 2>&1 ||  (echo '#  ' "install " /usr/obj/amd64.gcc.20240613/usr/include/krb5/ocsp_asn1.h;  echo "/usr/obj/tools.gcc/bin/x86_64--netbsd-install  -N /usr/src/etc -c  -r -o root -g wheel  -m 444 ocsp_asn1.h /usr/obj/amd64.gcc.20240613/usr/include/krb5/ocsp_asn1.h" &&  /usr/obj/tools.gcc/bin/x86_64--netbsd-install  -N /usr/src/etc -c  -r -o root -g wheel  -m 444 ocsp_asn1.h /usr/obj/amd64.gcc.20240613/usr/include/krb5/ocsp_asn1.h)
*** [/usr/obj/amd64.gcc.20240613/usr/include/krb5/ocsp_asn1.h] Error code 1
nbmake[7]: stopped in /usr/src/crypto/external/bsd/heimdal/lib/libhx509

I tried cvs updating to see if it was fixed, but that didn't show any
changes, and a rebuild from the same source tree (into a new empty
target dir) worked.

--- /usr/obj/amd64.gcc.20240613/usr/include/krb5/ocsp_asn1.h ---
#   install  /usr/obj/amd64.gcc.20240613/usr/include/krb5/ocsp_asn1.h
/usr/obj/tools.gcc/bin/x86_64--netbsd-install  -N /usr/src/etc -c  -r -o root -g wheel  -m 444 ocsp_asn1.h /usr/obj/amd64.gcc.20240613/usr/include/krb5/ocsp_asn1.h

I found this old pkgsrc problem:

but I think the src build doesn't use these Makefiles, does it?

Home | Main Index | Thread Index | Old Index